CRAN Package Check Results for Package hyperSpec

Last updated on 2019-09-23 03:48:59 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.99-20180627 15.20 226.57 241.77 WARN
r-devel-linux-x86_64-debian-gcc 0.99-20180627 11.57 169.74 181.31 NOTE
r-devel-linux-x86_64-fedora-clang 0.99-20180627 287.73 NOTE
r-devel-linux-x86_64-fedora-gcc 0.99-20180627 303.98 NOTE
r-devel-windows-ix86+x86_64 0.99-20180627 48.00 481.00 529.00 NOTE
r-patched-linux-x86_64 0.99-20180627 14.66 217.52 232.18 OK
r-patched-solaris-x86 0.99-20180627 348.40 NOTE
r-release-linux-x86_64 0.99-20180627 15.33 218.39 233.72 OK
r-release-windows-ix86+x86_64 0.99-20180627 47.00 428.00 475.00 NOTE
r-release-osx-x86_64 0.99-20180627 FAIL
r-oldrel-windows-ix86+x86_64 0.99-20180627 25.00 311.00 336.00 NOTE
r-oldrel-osx-x86_64 0.99-20180627 NOTE

Check Details

Version: 0.99-20180627
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building 'chondro.pdf.asis' using asis
    --- finished re-building 'chondro.pdf.asis'
    
    --- re-building 'fileio.pdf.asis' using asis
    --- finished re-building 'fileio.pdf.asis'
    
    --- re-building 'baseline.Rnw' using Sweave
    Loading required package: lattice
    Loading required package: grid
    Loading required package: ggplot2
    Package hyperSpec, version 0.99-20180627
    
    To get started, try
     vignette ("hyperspec")
     package?hyperSpec
     vignette (package = "hyperSpec")
    
    If you use this package please cite it appropriately.
     citation("hyperSpec")
    will give you the correct reference.
    
    The project homepage is http://hyperspec.r-forge.r-project.org
    
    
    start: 300 support points
    Iteration 1: 146 support points
    Iteration 2: 85 support points
    Iteration 3: 44 support points
    Iteration 4: 26 support points
    Iteration 5: 12 support points
    Iteration 6: 7 support points
    Iteration 7: 2 support points
    Warning in max(x@wavelength) :
     no non-missing arguments to max; returning -Inf
    Warning in min(x@wavelength) :
     no non-missing arguments to min; returning Inf
    Warning in max(x@wavelength) :
     no non-missing arguments to max; returning -Inf
    Warning in min(x@wavelength) :
     no non-missing arguments to min; returning Inf
    Iteration 8: 0 support points
    spectrum 1: 2 support points, noise = 0.0, 8 iterations
    Fitting with npts.min = 15
    
    start: 300 support points
    spectrum 1: 20 support points, noise = 0.0, 5 iterations
    Fitting with npts.min = 15
    
    start: 300 support points
    spectrum 1: 26 support points, noise = 0.0, 5 iterations
    Fitting with npts.min = 15
    
    start: 300 support points
    spectrum 1: 25 support points, noise = 0.0, 5 iterations
    Fitting with npts.min = 5
    
    start: 100 support points
    spectrum 1: 98 support points, noise = 4.0, 2 iterations
    Fitting with npts.min = 15
    
    start: 300 support points
    Iteration 1: 153 support points
    Iteration 2: 93 support points
    Iteration 3: 54 support points
    Iteration 4: 38 support points
    Iteration 5: 32 support points
    Iteration 6: 29 support points
    Iteration 7: 29 support points
    spectrum 1: 29 support points, noise = 15.0, 7 iterations
    Error: processing vignette 'baseline.Rnw' failed with diagnostics:
    Running 'texi2dvi' on 'baseline.tex' failed.
    LaTeX errors:
    ! Argument of \UTFviii@two@octets has an extra }.
    <inserted text>
     \par
    l.8 \bibitem[Liland and BjÃ(2015)]{baseline}
    
    ! Paragraph ended before \UTFviii@two@octets was complete.
    <to be read again>
     \par
    l.8 \bibitem[Liland and BjÃ(2015)]{baseline}
    
    ! Package inputenc Error: Invalid UTF-8 byte sequence.
    
    See the inputenc package documentation for explanation.
    Type H <return> for immediate help.
     ...
    --- failed re-building 'baseline.Rnw'
    
    --- re-building 'flu.Rnw' using Sweave
    Loading required package: lattice
    Loading required package: grid
    Loading required package: ggplot2
    Package hyperSpec, version 0.99-20180627
    
    To get started, try
     vignette ("hyperspec")
     package?hyperSpec
     vignette (package = "hyperSpec")
    
    If you use this package please cite it appropriately.
     citation("hyperSpec")
    will give you the correct reference.
    
    The project homepage is http://hyperspec.r-forge.r-project.org
    
    
    Read 362 items
    Read 362 items
    Read 362 items
    Read 362 items
    Read 362 items
    Read 362 items
    Warning in min(abs(diff(x@wavelength))) :
     no non-missing arguments to min; returning Inf
    Warning in min(abs(diff(x@wavelength))) :
     no non-missing arguments to min; returning Inf
    --- finished re-building 'flu.Rnw'
    
    --- re-building 'hyperspec.Rnw' using Sweave
    Loading required package: lattice
    Loading required package: grid
    Loading required package: ggplot2
    Package hyperSpec, version 0.99-20180627
    
    To get started, try
     vignette ("hyperspec")
     package?hyperSpec
     vignette (package = "hyperSpec")
    
    If you use this package please cite it appropriately.
     citation("hyperSpec")
    will give you the correct reference.
    
    The project homepage is http://hyperspec.r-forge.r-project.org
    
    
    Loading required namespace: mvtnorm
    Loading required package: MASS
    Warning in predict.lda(lda, chondro) :
     variable names in 'newdata' do not match those in 'object'
    Warning in rm(chondro) : object 'chondro' not found
    Loading required package: baseline
    
    Attaching package: 'baseline'
    
    The following object is masked from 'package:stats':
    
     getCall
    
    Warning in scores[, , 1:10] %*% loadings[1:10] :
     Dropping column(s) of y: filename, measurement
    Error: processing vignette 'hyperspec.Rnw' failed with diagnostics:
    Running 'texi2dvi' on 'hyperspec.tex' failed.
    LaTeX errors:
    ! Argument of \UTFviii@two@octets has an extra }.
    <inserted text>
     \par
    l.8 \bibitem[Liland and BjÃ(2015)]{baseline}
    
    ! Paragraph ended before \UTFviii@two@octets was complete.
    <to be read again>
     \par
    l.8 \bibitem[Liland and BjÃ(2015)]{baseline}
    
    ! Package inputenc Error: Invalid UTF-8 byte sequence.
    
    See the inputenc package documentation for explanation.
    Type H <return> for immediate help.
     ...
    --- failed re-building 'hyperspec.Rnw'
    
    --- re-building 'laser.Rnw' using Sweave
    Loading required package: lattice
    Loading required package: grid
    Loading required package: ggplot2
    Package hyperSpec, version 0.99-20180627
    
    To get started, try
     vignette ("hyperspec")
     package?hyperSpec
     vignette (package = "hyperSpec")
    
    If you use this package please cite it appropriately.
     citation("hyperSpec")
    will give you the correct reference.
    
    The project homepage is http://hyperspec.r-forge.r-project.org
    
    
    Loading required package: rgl
    plot chunk
    --- finished re-building 'laser.Rnw'
    
    --- re-building 'plotting.Rnw' using Sweave
    Loading required package: lattice
    Loading required package: grid
    Loading required package: ggplot2
    Package hyperSpec, version 0.99-20180627
    
    To get started, try
     vignette ("hyperspec")
     package?hyperSpec
     vignette (package = "hyperSpec")
    
    If you use this package please cite it appropriately.
     citation("hyperSpec")
    will give you the correct reference.
    
    The project homepage is http://hyperspec.r-forge.r-project.org
    
    
    Warning in (function (object, model = spc ~ c, groups = NULL, func = NULL, :
     Intensity at first wavelengh only is used.
    Warning in hyperSpec:::.levelplot(x, data, ...) :
     Only first wavelength is used for plotting
    Loading required namespace: deldir
    
     PLEASE NOTE: The components "delsgs" and "summary" of the
     object returned by deldir() are now DATA FRAMES rather than
     matrices (as they were prior to release 0.0-18).
     See help("deldir").
    
     PLEASE NOTE: The process that deldir() uses for determining
     duplicated points has changed from that used in version
     0.0-9 of this package (and previously). See help("deldir").
    
    
    Warning in plotc(x, ...) : Intensity at first wavelengh only is used.
    Warning in (function (x, y, z, subscripts, at = pretty(z), ..., col.regions = regions$col, :
     'x' values are not equispaced; output may be wrong
    Warning in hyperSpec:::.levelplot(x, data, ...) :
     Only first wavelength is used for plotting
    Loading required package: latticeExtra
    Loading required package: RColorBrewer
    
    Attaching package: 'latticeExtra'
    
    The following object is masked from 'package:ggplot2':
    
     layer
    
    Warning in (function (x, y, z, subscripts, at = pretty(z), ..., col.regions = regions$col, :
     'x' values are not equispaced; output may be wrong
    Warning in (function (x, y, z, subscripts, at = pretty(z), ..., col.regions = regions$col, :
     'y' values are not equispaced; output may be wrong
    Loading required package: rgl
    Warning: Using `as.character()` on a quosure is deprecated as of rlang 0.3.0.
    Please use `as_label()` or `as_name()` instead.
    This warning is displayed once per session.
    Warning: Ignoring unknown aesthetics: y
    --- finished re-building 'plotting.Rnw'
    
    SUMMARY: processing the following files failed:
     'baseline.Rnw' 'hyperspec.Rnw'
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-devel-linux-x86_64-debian-clang

Version: 0.99-20180627
Check: for non-standard things in the check directory
Result: NOTE
    Found the following files/directories:
     'flu.txt' 'test.mat'
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.99-20180627
Check: installed package size
Result: NOTE
     installed size is 5.1Mb
     sub-directories of 1Mb or more:
     doc 3.8Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-ix86+x86_64, r-patched-solaris-x86, r-release-windows-ix86+x86_64, r-release-osx-x86_64, r-oldrel-windows-ix86+x86_64, r-oldrel-osx-x86_64

Version: 0.99-20180627
Check: running R code from vignettes
Result: FAIL
    
Flavor: r-release-osx-x86_64